Telephone System Maintenance
Incident Report for catalyst2 Service Status
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 08:45 UTC
Identified
During the window below, our telephone system partner will be performing maintenance.

Customers can contact support teams via live chat, ticket and email but telephone contact will be unavailable.

WINDOW START 2024-11-11 19:00 GMT (19:00 UTC)

WINDOW END 2024-11-11 22:00 GMT (22:00 UTC)

EXPECTED IMPACT Customers will be unable to contact catalyst2 by telephone.

Our apologies for any disruption to support caused by these necessary works.
Posted Nov 11, 2024 - 14:23 UTC
This incident affected: Support and Phones.