Support E-Mail Issues

Incident Report for catalyst2 Service Status

Resolved

This incident has been resolved.
Posted Jun 23, 2023 - 10:01 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 23, 2023 - 09:57 UTC

Monitoring

We now have a workaround in place for this, if you have any issues contacting us please jump on live chat or call us. We will continue to monitor for now.
Posted Jun 09, 2023 - 19:23 UTC

Investigating

We are currenting experiencing an issue with our incoming support@catalyst2.com email address, please use shared@support.catalyst2.com for any initial communications until this is resolved. Apologies for any inconvenience caused.
Posted Jun 09, 2023 - 10:56 UTC
This incident affected: Support and Phones.